(release 1.4)
Copyright 2008-2013 Nine Vectors.
All Right Reserverd. http://www.ninevectors.com

Interface

If you have used before any other software for 3D graphics, then you should have no problems with assimilating Esquimo interface. It is based largely on solutions of applications already existing on the market. We did not want to invent the wheel, so wherever possible, we used the best practices. We wanted the study of Esquimo to be as short as possible.

Esquimo screen is divided into 3 panels: scene objects list, work area, edit panel.

At the top of the screen, there is also available the traditional menu, with access to the basic functions of the program. Depending on the needs, the area occupied by the various panels can be changed by dragging the line of division. If you like to use keyboard shortcuts (to which I strongly encourage you) you will certainly need a few keys to quickly switch the configuration of Eqsuimo screen:

Scene objects list

Each object placed in the scene or group of objects has a name under which it is also visible in the panel list of  “Scene objects list”. While clicking on one of the item of the list, there will be chosen the appropriate object in the scene and parameters of selected object are displayed in the Editing panel (bottom of the screen). Double click brings up a window where you can change a name of the item. Groups are shown as expandable bars (read more about Groups). Each position on the list has the icon name visibility on the left side. By clicking on the symbol of eye, you enable/disable the display of the object in the editor. The period of its visibility in the output file is defined in the Timeline editor (see the chapter titled "Timeline editor"). The name of the currently selected object is displayed in bold and the object in the work area is surrounded by yellow wire-frame box. Clicking on the trash icon or pressing the Delete key will remove the object or group of objects from the scene.

From the level of this panel, you can only select an object, decide whether it will be shown in a scene, clone or delete it. Cloning options of object are associated with animation keys, therefore see the chapter of Timeline editor for more details about the cloning of objects. Most of the parameters of the object itself can be changed in the Edit panel.

Work area

This is an area with viewing windows where you can manipulate objects in the case of their: translation, rotation, scaling and pivot point. At the top, the active window has a simplified statistic toolbar of created scene. It contains information about how many triangles and vertices in total are included in the displayed scene, and the current frame number as well as the name of the active view. Below the viewing windows, there is a time axis, used for moving during your animation. On its left, there are the icons for changing the mode of creation of new animation keys. See chapter called “Animation” in order to learn more about keying of animation.

To manipulate the views of workspace and objects in the scene, there exist functions activated by icons, arranged in a row below work area or appropriate keyboard shortcuts. By holding your mouse over the icon, you will get a hint about the function of icon and key shortcut for this function.

Esquimo work area - icons


A tip:You can move a view anytime without switching and leaving current manipulation mode. Pressing and holding down the SPACEbar temporarily switches to move view mode. Then drag the screen holding down left mouse button.

The first group of icons applies to manipulation of objects in the scene. Manipulations of objects such as: change of position, rotation, or scaling of the object are recorded on the timeline and have an impact on the final shape of the animation. Change of pivot point is not subjected to the registration on the timeline. Some of the icons, including “move pivot point” have a contextual menu caused by right-click of the mouse. Below, you will learn more about the manipulation of objects and pivot point.

Icons of the other groups concern settings of the viewing window in the workspace. Changes in settings of the viewing windows are not recorded on the timeline and do not affect the appearance of the final animation. They are used only to facilitate the work in progress of animation.

In certain circumstances, you will make a use of more than one camera. To set a view of the camera in the viewing window, make a right-click on the camera icon and select one from the context menu.

Camera - context menu

Take a few moments to get to know keyboard shortcuts that will greatly accelerate the work in Esquimo.

Create and modify panel

The lower part of the screen is occupied by both, the creation and editing panel. It is divided into sections under the following tabs:

Objects manipulation

Basic operations on the selected objects have to be made by you in the work area, using the additional elements that appear on the site – manipulators. Manipulation of objects such as: change of position, rotation, or scaling of the object are recorded on the timeline and have an impact on the final shape of the animation. Change of pivot point is not subjected to the registration on the timeline.

In the move mode  on the object, there appear additional arrows for each axis. While grabbing one of them, you can move an object, limiting yourself to only one coordinate. If you want to move an object limiting yourself to only one of three planes, hold the appropriate symbol - the square positioned between the arrows.

In the rotate mode the manipulators are 3 rings. . While grabbing one of them, you can rotate the object by sliding the mouse along a secondary line that appears in the time of selecting a foothold.

Scale mode allows you for stretching an object along a selected axis or along all axes, while keeping the proportions of scaled object.

Quick access to selected object

The selected object can by removed with DELETE key or by click on the bin icon in Scene objects list.

Pivot point

Each geometric object has the center of transformation - pivot point – on the basis of which it is possible to perform the rotation and scaling. Location of the pivot point does not affect the moving of object.

Important: Position of the pivot point is not animated. It is used only as a reference point for further modifications (rotating and scaling). Be aware that usage of pivot vary depending on whether "Geometry" or "Animate" mode is active. Read more...

Quick access to selected object

In the case of the icon "move pivot point”, after clicking on it with the right mouse button, you can access the following options:

Move pivot point - context menu

- Center pivot point - sets the pivot point of currently selected object in its geometric center.

- Select object as pivot point center - Moves the pivot point to the geometric center of the object, specified by clicking the left button of the mouse. It is quite useful function, in the situation, when you for example plan an animation where one object orbits another. Please note, that this function will only cause the movement of the pivot point in the center of another object, but does not binds them permanently. Let us suppose, that in the stage, there are located two objects a bit distant from each other - box and sphere. You want the box orbiting around the sphere while using "rotate" mode, so having the selected box you will use the function Select object as pivot point center indicating the sphere. Since now, the rotation of box takes place not on its own axis, but around the new center of rotation, which is established by the center of the sphere.

Important: Repositionig a pivot will effect in different ways for "Animation" and "Geometry" mode. See more about using pivot in Esquimo here.

Editor settings

Motion spline display

You can display a preview of trajectory of the moving object as a spline with dots (turned on by default). Spline has a number of dots ( if enabled - Show frame dots checkbox ), each single dot corresponds to single frame. The range of displayed dots can be set in Motion lenght field.

Snap

In many situations, the manipulation of objects can be facilitated by the snap mode. In the snap mode (S key), the transformation values are rounded to the number of values specified in the settings: Tools -> Options. This is useful, for example in the case of deploying objects in equal distances, or full rotation angles.

Quick access to selected object

Numerical object transforming

The precise values of the position, rotation or scale of object can be entered as numeric values from the keyboard ( Timeline -> Numerical object transform or  F8 key ). It is also possible to enter the relative values after the selection of checkbox Offset values. Depending on the mode in which you are located, after pressing F8, there will be shown one of the following dialogs.

Quick access to selected object

Grid

Orientation in space is facilitated by the auxiliary grid. Enabled by default, but can be necessarily turned off ( View -> Show grid or G key). Initially, the size of boxes in the grid is equal to one unit. The grid is thickened or enlarged, depending on the magnification of the current viewing window.

Wireframe viewport display mode

It comes very handy when some objetcts that you need an access to are obscured by others. For example a camera inside of torus with filled surface may be very unhandy to manipulate because the surface of the torus covers the icons of camera. You can toggle a display mode to wireframe (press SHIFT+W ) so that you can see throught all the objects in the scene.

Wireframe mode toggling in viewport

Additional options

Export-> Export hidden objects - output SWF displays objects which have Visibility parametr unchecked. Normally they are not included in final SWF.
Display-> Use scene background color - if unchecked a background of work area takes a light gray color. If you check this option editor's background color will be getting the color from Background color in Scenetab.
Default scene settings-> Background color - The value will be assigned to   Background color parameter in Scenetab when you create new scene.
 

Keyboard shortcuts

Esquimo has a preset set of keys, on which the following manual is based. They were selected on the basis of over-dozen-month work with the program, at the time of its creation. Obviously, you can also assign your own keyboard shortcuts for the selected functions. Invoke a table of keyboard shortcuts by the combination of the following buttons: CTRL+ALT+SHIFT+K, or from the main menu Tools-> Keyboard shortcuts

Define your own shortcuts

If you want to assign a new shortcut, select the appropriate position from the list, click on the text box – Shortcut and key / key combinations, which you want to assign. If the shortcut has been already taken, there will be displayed the appropriate information, if it is free, just confirm its choice by Assign shortcut button. Without approval, the shortcut will not be assigned. Reset all shortcuts button restores default set of the shortcuts.